R1
__
interface loopback 0
ip address 1.1.1.1 255.255.255.255
interface serial 1/0
encapsulation frame-relay
ip address 192.168.1.1 255.255.255.0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay map ip 192.168.1.3 103 broadcast
ip ospf network-type point-to-multipoint
router ospf 1
network 192.168.1.1 0.0.0.0 area 0
network 1.1.1.1 0.0.0.0 area 0
R2
__
interface loopback 0
ip address 2.2.2.2 255.255.255.255
interface serial 1/0
encapsulation frame-relay
ip address 192.168.1.2 255.255.255.252
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay map ip 192.168.1.3 201
ip ospf network-type point-to-multipoint
router ospf 1
network 192.168.1.2 0.0.0.0 area 0
network 2.2.2.2 0.0.0.0 area 0
R3
__
interface loopback 0
ip address 3.3.3.3 255.255.255.255
interface serial 1/0
encapsulation frame-relay
ip address 192.168.1.3 255.255.255.0
frame-relay map ip 192.168.1.2 301 broadcast
frame-relay map ip 192.168.1.1 301 broadcast
router ospf 1
network 192.168.1.3 0.0.0.0 area 0
network 3.3.3.3 0.0.0.0 area 0
4 comments:
Thanks Steve B for submitting the answer.
Remember that you can add your answers to the comment field
From Steve:
The first issue I see is that R3 is configured for NBMA while R1 and R2 are configured to use point-to-multipoint ospf network types. I'm not sure what the restrictions are but changing the network type should bring up the neighbor.
I also do notice a second thing with R2 which has a /30 netmask while R1 and R3 have /24's. You may run into strange things with this config so if you change it to match with a /24 you should now have full reachability.
So IP mismatch and network type mismatch is what I see here…
I have also added the correct pieces of the configuration:
R1 -
Configuration is good
R2 -
no ip address 192.168.1.2 255.255.255.252
ip address 192.168.1.2 255.255.255.0
R3 -
ip ospf network-type point-to-multipoint
Note: it is "ip ospf network point-to-multipoint" and not "ip ospf network-type point-to-multipoint" . Typo X2 ;)
also the frame-relay mapping at R3 for R2 needs to correct as 302.
Asif
That may be true if this was a full mesh but it is not. There is no PVC between R2 and R3 and therefore a frame-map is not required.
Post a Comment