This blog was originally started to better help me understand the technologies in the CCIE R&S blueprint; after completing the R&S track I have decided to transition the blog into a technology blog.
CCIE #29033
This blog will continue to include questions, troubleshooting scenarios, and references to existing and new technologies but will grow to include a variety of different platforms and technologies. Currently I have created over 185 questions/answers in regards to the CCIE R&S track!! Note: answers are in the comment field or within "Read More" section.
You can also follow me on twitter @FE80CC1E
RB should have a default route to serial 1/0 (172.16.18.252) on RA. Domain name, DNS, netbios, netbios type, and lease is required. Lab it up if required.
RA
__
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.18.1 172.16.18.254
!
ip dhcp pool 0
network 172.16.0.0 255.255.0.0
domain-name packetsanalyzed.com
dns-server 172.16.1.250 172.16.2.251
netbios-name-server 172.16.1.18
default-router 172.16.18.252 172.16.18.253
netbios-node-type p-node
lease 30
!
ip dhcp pool 1
network 172.16.18.0 255.255.255.0
default-router 10.0.0.1
!
ip dhcp pool 2
network 172.16.22.0 255.255.255.0
dns-server 172.16.22.250 172.16.22.251
interface Serial1/0
ip address 172.16.18.253 255.255.255.0
ip address 172.16.18.252 255.255.255.0 secondary
encapsulation ppp
peer default ip address dhcp-pool 0
serial restart-delay 0
no fair-queue
RB
__
interface FastEthernet0/1
ip address 10.0.0.250 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address negotiated
encapsulation ppp
serial restart-delay 0
no fair-queue
do sh ip route
Gateway of last resort is not set
172.16.0.0/32 is subnetted, 2 subnets
C 172.16.18.253 is directly connected, Serial1/0
C 172.16.18.13 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/1
3 comments:
Without knowing exactly what I can and can't do here this is what I have come up with. Also for clarification purposes my serial interfaces are s2/0
With the default configuration I was pulling an IP of 172.16.0.1
RB(config-if)#do sh ip int br | ex un
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 10.0.0.250 YES manual up up
Serial2/0 172.16.0.1 YES IPCP up up
The second thing that I notice is that we are excluding the entire range for 172.16.18.0/24, I chose to modify this as follows
no ip dhcp excluded-address 172.16.18.1 172.16.18.254
ip dhcp excluded-address 172.16.18.252 172.16.18.253
Most of what we want is in pool 0 however the pool for this range is 1 so I have added in all of the info from pool 0 to 1 (with the exception of the network which already exists) also the default router is on an entirely different subnet so that also has changed
ip dhcp pool 1
no default-router 10.0.0.1
domain-name packetsanalyzed.com
dns-server 172.16.1.250 172.16.2.251
netbios-name-server 172.16.1.18
default-router 172.16.18.252 172.16.18.253
netbios-node-type p-node
lease 30
One more thing on RA will be to modify the s2/0, otherwise our default route will be pointing to the wrong IP
interface Serial2/0
no ip address 172.16.18.252 255.255.255.0 secondary
no ip address 172.16.18.253 255.255.255.0
ip address 172.16.18.252 255.255.255.0
ip address 172.16.18.253 255.255.255.0 secondary
no peer default ip address dhcp-pool 0
peer default ip address dhcp-pool 1
Assuming no ip route commands we can set the default route via IPCP
RB
int s2/0
ppp ipcp route default
So now let's test this
RA
no ip dhcp excluded-address 172.16.18.1 172.16.18.254
ip dhcp excluded-address 172.16.18.252 172.16.18.253
ip dhcp pool 1
no default-router 10.0.0.1
domain-name packetsanalyzed.com
dns-server 172.16.1.250 172.16.2.251
netbios-name-server 172.16.1.18
default-router 172.16.18.252 172.16.18.253
netbios-node-type p-node
lease 30
interface Serial2/0
no ip address 172.16.18.252 255.255.255.0 secondary
no ip address 172.16.18.253 255.255.255.0
ip address 172.16.18.252 255.255.255.0
ip address 172.16.18.253 255.255.255.0 secondary
no peer default ip address dhcp-pool 0
peer default ip address dhcp-pool 1
RB
Int s2/0
ppp ipcp route default
RB(config-if)#do sh ip int br | ex un
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 10.0.0.250 YES manual up up
Serial2/0 172.16.18.15 YES IPCP up up
RB(config-if)#do sh ip route
Gateway of last resort is 172.16.18.252 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.18.252/32 is directly connected, Serial2/0
C 172.16.18.15/32 is directly connected, Serial2/0
S 172.16.0.0/16 [1/0] via 172.16.18.252
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 [1/0] via 172.16.18.252
So I don’t know if this satisfies the requirements or breaks the rules??
Happy labbing!
Great stuff!
This is the solution I was looking for. The next troubleshooting scenario will include more requirements.
BTW: There was some additional solutions that I am still reviewing that may get added.
Good stuff Steve!
Jason, I do enjoy these and seeing what people come up with, some people have very creative solutions that I wouldn't have thought of :P
This is great a great learning experience, so thanks for posting these!
Post a Comment