This blog was originally started to better help me understand the technologies in the CCIE R&S blueprint; after completing the R&S track I have decided to transition the blog into a technology blog.
CCIE #29033

This blog will continue to include questions, troubleshooting scenarios, and references to existing and new technologies but will grow to include a variety of different platforms and technologies. Currently I have created over 185 questions/answers in regards to the CCIE R&S track!! Note: answers are in the comment field or within "Read More" section.

You can also follow me on twitter @FE80CC1E

Monday, November 29, 2010

Question 177

What path attributes would you use to manipulate where outgoing traffic exits?

Question 176

What is the path attributes used to manipulate return traffic?

Monday, November 15, 2010

Just Another Day for an IT Professional

Wednesday, November 10, 2010

Question 175

What command can display all traffic destined to a router? Note: IP Traffic

Tuesday, November 9, 2010

Troubleshooting 6

Here we go with another simple but interesting troubleshooting scenario


Ensure that R1 can ping R2 and ensure any optimizations are retained.  Interfaces are in an up/up state and there are no ACL or security features restricting access. Some configuration and debug outputs are included below. Please provide a working configuration.


R1
__

R1(config)#do ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


interface Serial1/0
 ip address 10.0.0.1 255.255.255.0
 load-interval 30
 serial restart-delay 0
end


R2
__

R2#
*Mar  1 01:31:40.499: Serial1/0: COMPRESS: (expansion) status: 6, size in: 20, size out: 15
*Mar  1 01:31:50.499: Serial1/0: COMPRESS: (expansion) status: 6, size in: 20, size out: 15
*Mar  1 01:32:00.499: Serial1/0: COMPRESS: (expansion) status: 6, size in: 20, size out: 15
*Mar  1 01:32:10.499: Serial1/0: COMPRESS: (expansion) status: 6, size in: 20, size out: 15



Monday, November 8, 2010

Question 174

What PIM mode is required for BSR?

Question 173

What PIM mode is required for AutoRP?

Sunday, November 7, 2010

Challenge 2

Challenge 2
___________

You must configure R1 to leverage the two Content Engines. R1 must ensure that it can only communicate with 192.168.0.100 and 192.168.0.101 content engines. Hosts on 10.0.2.0/24 should not use the content engines and should be able to surf the internet without being redirected. Hosts on 10.0.1.0/24 should be redirected to the content engines. The configuration should only be completed on R1. Note: You must use the latest version of the technology and it must support authentication.




R1
__


interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial1/0
 ip address 200.0.0.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute static metric 5 subnets
 network 10.0.0.1 0.0.0.0 area 0
 network 192.168.0.1 0.0.0.0 area 0
 network 200.0.0.1 0.0.0.0 area 0
!
ip route 0.0.0.0 0.0.0.0 200.0.0.2


R2
__

interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface FastEthernet1/0
 no switchport
 ip address 10.0.2.1 255.255.255.0
 no keepalive
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.0.0.2 0.0.0.0 area 0
 network 10.0.1.1 0.0.0.0 area 0
 network 10.0.2.1 0.0.0.0 area 0



R3
__ -- Acting as the hext hop to the internet

interface Serial1/0
 ip address 200.0.0.2 255.255.255.0
 serial restart-delay 0

!
ip route 10.0.0.0 255.255.255.0 200.0.0.1
ip route 10.0.1.0 255.255.255.0 200.0.0.1
ip route 10.0.2.0 255.255.255.0 200.0.0.1
ip route 192.168.0.0 255.255.255.0 200.0.0.1




Good Luck!

Saturday, November 6, 2010

Question 172

What PIM mode leverages shared trees and what PIM mode leverage source trees?

Question 171

How do you delete RSA key pairs or a single RSA key pair?

Friday, November 5, 2010

Question 170

What technology uses IP address 224.0.1.39 and 224.0.1.40?



Question 169

What does TTCP provide?

Tuesday, November 2, 2010

Question 168

What command can be used to ensure that if a port receives a BPDU the port is put into errdisable state?

Question 167

What command can be used to ensure that BPDU's that are received on a port disables the portfast feature?

Question 166

What command can be used to ensure that BPDU's are not transmitted or received on a port?

What is the risk of using this command?

Monday, November 1, 2010

Question 165

What command can be used to validate multicast reverse path forwarding for 10.0.0.1?

Image courtesy of Dongle
This is to further support the comments below

Question 164

I have put a couple of questions together about TCL (Tool Command Language)


How do you determine if your IOS supports TCL interpreter?
How do you determine the TCL version?
How do you determine the TCL patch level?
What command is used to view a variable?