This blog was originally started to better help me understand the technologies in the CCIE R&S blueprint; after completing the R&S track I have decided to transition the blog into a technology blog.
CCIE #29033

This blog will continue to include questions, troubleshooting scenarios, and references to existing and new technologies but will grow to include a variety of different platforms and technologies. Currently I have created over 185 questions/answers in regards to the CCIE R&S track!! Note: answers are in the comment field or within "Read More" section.

You can also follow me on twitter @FE80CC1E

Saturday, May 28, 2011

CCIE Journey Ends and Life Long Learning Continues

The CCIE Journey Ends and Life Long Learning Continues..........

I passed the CCIE exam on May 25, 2011 and I have to say that it was long and a difficult process. Most of us perusing the elite certification continue to work fulltime and try balancing between our families and studying which makes the process that much more difficult.  I will break this up into 2 sections, the first section will give a summary of studying material and tools used during the process and the second section will give some insight into San Jose and RTP.

Primary Study Tools
·         IPX Blended Learning Solution (BLS) / Self-Study Bundle  - (IPX provided me the core foundation and additional hands on experience required to achieve the CCIE designation.)
o   Video on Demand Course
o   Volume 1 Workbook and Walk Through Videos
o   Volume 2 Workbook
o   Volume 3 Workbook and Walk Through Videos
o   Proctors Labs (Rack Time)
o   Audio Book
·         CCIE R&S Reading List -(The CCIE reading list provided me a great list of books to ensure that I understood the technology  to depth required to become an expert.)
·          Cisco Doc-CD - (The Doc-CD should be used in your day to day job as this ensures that you are implementing technologies that Cisco offers from the makers of the technologies. The ones that know it best)
·         IPX Online Study Group – Leveraging the OSL allows you to participate in problems that others are facing during their studies, gain insight into how others are approaching things, gives you a forum to discuss anything in regards to your journey. Not to mention that there are multiple experts contributing to this forum.
·         Blog  - This was the avenue that I took as it made me dig even deeper into the technologies as I was posting and creating material for the world to view.  My site has a slew of questions that I created, troubleshooting scenarios, and just information about technologies.
·         Working with the technologies in your day to day job – This one may be obvious but I included anyways

Secondary Study Tools
·          INE - (INE gave me an opportunity to work with different workbooks that are structured and worded differently – helped get me out of the my comfort level when working with only 1 type of workbook)
·          Graded Labs (Rack Time) – Same as the above and I needed to be able to work with the topologies that were specific to INE
·          Dynamips – Allowed me to create my own LABs as well as leverage it to run IPX and INE labs when I could not be bothered to schedule a lab and be bound to a timeline

Sunday, May 22, 2011

Quick Notes - NTP Update-Calendar

There are some platforms that have a hardware clock that is powered by a battery. This is in addition to the software based clock. The software clock is synchronized to an external time source via NTP. At times the hardware clock may drift if it is not periodically updated by the software clock. It is best practice to update the hardware clock periodically with the software clock.

"ntp update-calendar" updates the hardware clock

Friday, May 20, 2011

Quick Notes - Prefix-List Matching Class A,B,C

Prefix lists can be used to match a complete address class

Class A = 1.0.0.0 – 126.255.255.255
Class B = 128.0.0.0 – 191.255.255.255
Class C = 192.0.0.0 – 223.255.255.255


The classes can be defined by the starting bits in the first octet


Class A = 0
Class B = 10
Class C = 110



In order to match Class A, B, or C you need to perform the following:

Sunday, May 15, 2011

Quick Notes - Administrative Distance

0     - Connected
1     - Static
5     - EIGRP Summary Route
20   - eBGP
90   - EIGRP
100 - IGRP
110 - OSPF
120 - RIP
160 - ODR
170 - EIGRP External Route
200 - iBGP
255 - Unknown

Cisco CRS-3 - Foundation for the Next-Gen Internet

Tuesday, May 10, 2011

Quick Notes - MPLS

Quick Notes - BGP Dampening with route-map

ip prefix-list XY seq 5 permit 10.0.0.0/15 le 32

route-map DAMPENING permit 10
 match ip address prefix-list XY
 set dampening 15 750 2000 60

router bgp 100
 bgp dampening route-map DAMPENING
 neighbor 192.168.0.2 remote-as 200

Cisco CRS-3

Monday, May 9, 2011

Quick Notes - IRB - IEEE

BBBB must be able to connect to AAAA and vice versa. Layer2 must be used on hub and AAAA/BBBB must leverage layer 3 ports on the directly connected interface.

Sunday, May 8, 2011

Quick Notes - Multicast Boundry

In order to ensure AutoRP and the administratively scoped multicast addresses do not leak outside or into your multicast domain you need to filter the following:

224.0.1.40 - The Cisco multicast router AUTO-RP-DISCOVERY address is the destination address for messages from the RP mapping agent to discover candidates
224.0.1.39 - The Cisco multicast router AUTO-RP-ANNOUNCE address is used by RP mapping agents to listen for candidate announcements
239.0.0.0/8 - Administratively Scoped



Monday, May 2, 2011

Quick Notes - MPLS and OSPF

You must enable MPLS but you cannot enable "mpls ip" on the interface. Current network is leveraging OSPF.

R1

interface Serial1/0
 ip address 192.168.0.1 255.255.255.0
interface Serial1/1
 ip address 192.168.2.1 255.255.255.0

router ospf 1
 mpls ldp sync (this ensures that MPLS waits for the IGP to be fully synchronized before issuing labels - not required for the configuration)
 mpls ldp autoconfig area 0 (this enables MPLS on all interfaces that are in area 0)
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

R2

interface Serial1/0
 ip address 192.168.0.2 255.255.255.0
interface Serial1/1
 ip address 192.168.2.2 255.255.255.


router ospf 1
 mpls ldp sync
 mpls ldp autoconfig
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

Quick Notes - IPV6 DHCP Example

Server
ipv6 dhcp pool IPV6-2001
 prefix-delegation pool IPV6-2001
 dns-server 2001:2001::100

ipv6 dhcp pool IPV6-2002
 prefix-delegation pool IPV6-2002
 dns-server 2001:2001::100

ipv6 local pool IPV6-2001 2001:2001::/64 64
ipv6 local pool IPV6-2002 2002:2002::/64 64

interface Serial1/0
 ipv6 address 2001:2001::1/64
 ipv6 enable
 ipv6 dhcp server IPV6-2001
 serial restart-delay 0

interface Serial1/1
 ipv6 address 2002:2002::1/64
 ipv6 enable
 ipv6 dhcp server IPV6-2002
 serial restart-delay 0

Client
interface Serial1/0
 description CONN-IPV6-DHCP-PROVIDER
 ipv6 address FE80::2 link-local
 ipv6 address IPV6-2001 ::2/64
 ipv6 enable
 ipv6 dhcp client pd IPV6-2001
 serial restart-delay 0


interface Serial1/1
 description CONN-IPV6-CLIENTS
 ipv6 address FE80::2 link-local
 ipv6 dhcp client pd IPV6-2002
 ipv6 address IPV6-2002 ::2/64
 ipv6 enable
 serial restart-delay 0

Sunday, May 1, 2011

Quick Notes - PPP no peer neighbor-route

Peer neighbor routes are required when the PPP neighbors IP address is on a different subnet. This will create a host connected route in the routing table. When both peers IP address are on the same subnet then use "no peer neighbor-route". A couple of scenarios where you may have peer neighbors in different subnets include:
-Virtual-template interfaces
-IP unnumbered interfaces
-Multilink interfaces
-IPCP negotiated address

"peer neighbor-route" is enabled by default.