This blog was originally started to better help me understand the technologies in the CCIE R&S blueprint; after completing the R&S track I have decided to transition the blog into a technology blog.

CCIE #29033

This blog will continue to include questions, troubleshooting scenarios, and references to existing and new technologies but will grow to include a variety of different platforms and technologies. Currently I have created over 185 questions/answers in regards to the CCIE R&S track!! Note: answers are in the comment field or within "Read More" section.

You can also follow me on twitter @FE80CC1E


Sunday, October 17, 2010

Question 141

How do you ensure that any packet sized from 64 - 99 bytes uses serial 1/0 and packets sized 100 - 1000 bytes uses serial 1/1? All other packets use the best route. Provide an example



1 comments:

Packets Analyzed said...

R1
__

interface FastEthernet0/1
no ip address
ip policy route-map PBR_Q141
duplex auto
speed auto
no keepalive
!
interface Serial1/0
ip address 10.0.0.1 255.255.255.0
serial restart-delay 0
no fair-queue
!
interface Serial1/1
ip address 10.0.1.1 255.255.255.0
serial restart-delay 0

router eigrp 1
passive-interface default
no passive-interface FastEthernet0/1
no passive-interface Serial1/0
no passive-interface Serial1/1
network 10.0.0.1 0.0.0.0
network 10.0.1.1 0.0.0.0
network 192.168.1.0
no auto-summary
!
ip local policy route-map PBR_Q141 (this was included so we can test using locally generated traffic)
!
route-map PBR_Q141 permit 10
match length 64 99
set interface Serial1/0
!
route-map PBR_Q141 permit 20
match length 100 1000
set interface Serial1/1



enable "debug ip policy"

R1#ping 172.16.1.2 size 40

Type escape sequence to abort.
Sending 5, 40-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/93/104 ms
R1#
*Mar 1 00:29:11.627: IP: s=10.0.0.1 (local), d=172.16.1.2, len 40, policy rejected -- normal forwarding

R1#ping 172.16.1.2 size 64

Type escape sequence to abort.
Sending 5, 64-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/93/116 ms
R1#
*Mar 1 00:17:05.279: IP: s=10.0.1.1 (local), d=172.16.1.2, len 64, policy match
*Mar 1 00:17:05.283: IP: route map PBR_Q141, item 10, permit
*Mar 1 00:17:05.283: IP: s=10.0.1.1 (local), d=172.16.1.2 (Serial1/0), len 64, policy routed


R1#ping 172.16.1.2 size 100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/88/100 ms
R1#
*Mar 1 00:18:50.711: IP: s=10.0.1.1 (local), d=172.16.1.2, len 100, policy match
*Mar 1 00:18:50.715: IP: route map PBR_Q141, item 20, permit
*Mar 1 00:18:50.715: IP: s=10.0.1.1 (local), d=172.16.1.2 (Serial1/1), len 100, policy routed

Post a Comment