Mutlilink PPP fragments traffic by default and this can be leveraged by QOS. To reduce serialization delay perform the following:
Create multilink interface
interface multilink 1
ip address 1.1.1.1 255.255.255.0
ppp multilink (this enables fragmentation on the multilink interface)
ppp multilink interleave (this enables interleaving)
ppp fragment-delay [delay] (specifies how long the fragment will take to leave the interface in milliseconds)
Assign the virtual template to the physical interface
interface serial 0/0/0
encapsualtion ppp
multilink-group 1
R1
__
interface Multilink1
ip address 1.1.1.1 255.255.255.0
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 1
end
interface Serial1/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
end
R2
__
interface Multilink1
ip address 1.1.1.2 255.255.255.0
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 1
end
interface Serial1/2
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
end
R2(config-if)#do show ppp multilink
Multilink1, bundle name is R1
Endpoint discriminator is R1
Bundle up for 00:01:40, total bandwidth 1544, load 1/255
Receive buffer limit 12000 bytes, frag timeout 1000 ms
Interleaving disabled
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x7 received sequence, 0x7 sent sequence
Member links: 1 active, 1 inactive (max not set, min not set)
Se1/0, since 00:01:41, 1930 weight, 1496 frag size
Vt1 (inactive)
No inactive multilink interfaces
Disabled!! but....... well you have to use a policy map and set the bandwidth.
class-map match-all CMAP
match any
policy-map PMAP
class CMAP
bandwidth 512
interface Multilink1
service-policy output PMAP
R2(config)#do sh ppp multilink
Multilink1, bundle name is R1
Endpoint discriminator is R1
Bundle up for 00:22:25, total bandwidth 1544, load 1/255
Receive buffer limit 12000 bytes, frag timeout 1000 ms
Interleaving enabled
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x1C received sequence, 0x1C sent sequence
Member links: 1 active, 1 inactive (max not set, min not set)
Se1/0, since 00:17:28, 1930 weight, 1496 frag size
Vt1 (inactive)
No inactive multilink interfaces
Thats better!
Exploring the Splunk Web Interface | Major Features and Preferences Welcome
to this in-depth guide to the Splunk Web interface! In this video, we
explore...
1 month ago
0 comments:
Post a Comment